Aruba Central Online Help

Sample Template and Variables Files

Template Text

The following example shows the contents of a Gateway configuration template:

vlan 4094

!

interface gigabitethernet 0/0/0

switchport access vlan 4094

trusted

trusted vlan 1-4094

!

interface gigabitethernet 0/0/1

!

interface gigabitethernet 0/0/2

!

interface gigabitethernet 0/0/3

!

interface gigabitethernet 0/0/4

!

interface gigabitethernet 0/0/5

!

interface gigabitethernet 0/0/6

!

interface gigabitethernet 0/0/7

!

interface gigabitethernet 0/0/8

!

interface gigabitethernet 0/0/9

!

interface gigabitethernet 0/0/10

!

interface gigabitethernet 0/0/11

!

interface gigabitethernet 0/0/12

!

interface gigabitethernet 0/0/13

!

interface gigabitethernet 0/0/14

!

interface gigabitethernet 0/0/15

!

interface gigabitethernet 0/0/16

switchport access vlan %_vlan_id3_%

!

interface gigabitethernet 0/0/17

switchport access vlan %_vlan_id1_%

!

interface vlan 4094

ip address dhcp-client

!

firewall

dpi

cp-bandwidth-contract trusted-ucast 65535

cp-bandwidth-contract trusted-mcast 3906

cp-bandwidth-contract untrusted-ucast 9765

cp-bandwidth-contract untrusted-mcast 3906

cp-bandwidth-contract route 976

cp-bandwidth-contract sessmirr 976

cp-bandwidth-contract vrrp 512

cp-bandwidth-contract auth 976

cp-bandwidth-contract arp-traffic 3906

cp-bandwidth-contract l2-other 1953

!

mgmt-user admin root itsabug

interface vlan 4094

ip address dhcp-client

!

hostname %_hostname_%

vlan %_vlan_id_%

interface vlan %_vlan_id_%

ip address %_ip_addr_% %_net_mask_%

!

controller-ip vlan %_vlan_id_%

!

wlan virtual-ap %_vap1_%

aaa-profile %_prof_name7_%

vlan %_vlan_id3_%

!

aaa server-group %_svr_grp1_%

auth-server %_svr1_%

!

aaa server-group %_svr_grp2_%

auth-server %_svr1_%

!

aaa server-group %_svr_grp3_%

auth-server %_svr1_%

!

aaa server-group %_svr_grp4_%

auth-server %_svr1_%

!

aaa server-group %_svr_grp5_%

auth-server %_svr1_%

!

aaa server-group %_svr_grp6_%

auth-server %_svr1_%

!

crypto-local pki ServerCert new_svr1_ocsp new_svr1_ocsp

crypto-local pki ServerCert SERVER-CERT SERVER-CERT

crypto-local pki TrustedCA pata_ca pata_ca

crypto-local pki rcp pata_ca

aaa authentication dot1x %_pdot1x_%

server-cert %_svr_cert_%

ca-cert %_ca_cert_%

!

aaa authentication-server radius %_svr1_%

!

vlan %_vlan_id1_%

wired aaa-profile %_prof_name7_%

!

aaa profile %_prof_name7_%

initial-role %_role1_%

dot1x-default-role %_role1_%

dot1x-server-group %_svr_grp1_%

!

aaa profile %_prof_name5_%

initial-role %_role1_%

dot1x-default-role %_role1_%

!

vlan %_vlan_id2_%

wired aaa-profile %_prof_name5_%

!

user-role %_role1_%

!

vlan %_vlan_id3_%

!

interface vlan %_vlan_id2_%

ip address %_ip_vlan2_% %_net_mask_%

!

ip access-list session %_acl1_%

!

aaa server-group %_svr_grp1_%

auth-server %_svr1_%

!

aaa authentication-server radius %_svr1_%

!

vlan 3434

!

netdestination peds-devices

%if local_network_ip%

range %local_network_ip%.91 %local_network_ip%.100

range %local_network_ip%.101 %local_network_ip%.110

%endif%

!

aaa profile %_prof_name8_%

%if role_group%

%role_group%

%endif%

!

aaa authentication captive-portal %_cap1_%

redirect-url "https://abc%xyz"

!

user

user

Sample Variables File

The following example shows the contents of a sample variables file in the JSONJavaScript Object Notation. JSON is an open-standard, language-independent, lightweight data-interchange format used to transmit data objects consisting of attribute–value pairs. JSON uses a "self-describing" text format that is easy for humans to read and write, and that can be used as a data format by any programming language. format:

"CG0011297": {

"_sys_lan_mac": "00:0B:86:dd:67:80",

"_sys_serial": "CG0011297",

"_hostname_": "Aruba7010_DD_67_80",

"_vlan_id_" : "700",

"_ip_addr_" : "1.70.70.10",

"_net_mask_" : "255.255.255.0",

"_vlan_id1_" : "225",

"_vlan_id2_" : "226",

"_vlan_id3_" : "227",

"_prof_name5_" : "prof5",

"_prof_name6_" : "prof6",

"_prof_name7_" : "prof7",

"_prof_name9_" : "prof9",

"_role1_" : "role1",

"_ip_vlan2_" : "1.27.26.10",

"_vap1_" : "vap1",

"_svr_grp1_" : "svr_grp1",

"_svr_grp2_" : "svr_grp2",

"_svr_grp3_" : "svr_grp3",

"_svr_grp4_" : "svr_grp4",

"_svr_grp5_" : "svr_grp5",

"_svr_grp6_" : "svr_grp6",

"_svr1_" : "svr1",

"_svr_cert_" :"new_svr1_ocsp",

"_ca_cert_" : "pata_ca",

"_pdot1x_" : "pdot1x",

"_server_ocsp3_" : "server_ocsp3",

"_acl1_" : "acl1",

"local_network_ip" : "34.34.54",

"_prof_name8_" : "prof8",

"role_group" : "initial-role role1\n dot1x-default-role role1",

"_cap1_" : "cap1",

"_url_" : "https://abc/%xyz",

"_role2_" : "\"test%role2\""

},

"CG0007810": {

"_sys_lan_mac": "00:0B:86:dB:B0:C0",

"_sys_serial": "CG0007810",

"_hostname_": "Aruba7010_DB_B0_C0",

"_vlan_id_" : "166",

"_ip_addr_" : "166.10.10.10",

"_net_mask_" : "255.255.255.0",

"_vlan_id1_" : "225",

"_vlan_id2_" : "226",

"_vlan_id3_" : "227",

"_prof_name5_" : "prof5",

"_prof_name6_" : "prof6",

"_prof_name7_" : "prof7",

"_prof_name9_" : "prof9",

"_role1_" : "role1",

"_ip_vlan2_" : "1.27.26.11",

"_vap1_" : "vap1",

"_svr_grp1_" : "svr_grp1",

"_svr_grp2_" : "svr_grp2",

"_svr_grp3_" : "svr_grp3",

"_svr_grp4_" : "svr_grp4",

"_svr_grp5_" : "svr_grp5",

"_svr_grp6_" : "svr_grp6",

"_svr1_" : "svr1",

"_svr_cert_" :"new_svr1_ocsp",

"_ca_cert_" : "pata_ca",

"_pdot1x_" : "pdot1x",

"_server_ocsp3_" : "server_ocsp3",

"_acl1_" : "acl1",

"local_network_ip" : "34.34.54",

"_prof_name8_" : "prof8",

"role_group" : "initial-role role1\n dot1x-default-role role1",

"_cap1_" : "cap1",

"_url_" : "https://abc/%xyz",

"_role2_" : "\"test%role2\""

}